1. Welcome to the shiny new site! Please have a look around and let us know how its working for you. Please note that all returning members will need to reset your passwords to login again. Click on "forgot password" to reset your password. If you still have issues then email us at board@marinecolorado.org Thanks
    Dismiss Notice
Dismiss Notice
Site Upgrade complete! A new version of the forum software has been uploaded. Please let us know if you have any issues. Thanks

please help !!!

Discussion in 'Lighting and Equipment' started by tony02133, Jun 2, 2018.

  1. tony02133

    tony02133 Cuttle Fish M.A.S.C Club Member

    im having trouble with a 4 stage spectra pure rodi unit just replace all the filters and is producing water really fast with 0 tds ,is this normal to happen never have this problem before, thanks in advance
     
  2. zombie

    zombie Tuna M.A.S.C Club Member

    Pics of how its connected and what kind of rate you are seeing would help. Short answer is no that is not normal. Flow should be a slow and steady drip unless you have multiple membranes.

    Sent from my SM-G965U using MASC mobile app
     
  3. tony02133

    tony02133 Cuttle Fish M.A.S.C Club Member

  4. zombie

    zombie Tuna M.A.S.C Club Member

    I can't see all the connections from that photo including where the waste flow restrictor is, where the TDS meter is tied in or which output tube you are using is. Can you take some more angles and try to include every part and piece in at least one photo or a video.

    Sent from my SM-G965U using MASC mobile app
     
  5. tony02133

    tony02133 Cuttle Fish M.A.S.C Club Member

  6. SynDen

    SynDen Shark Staff Member M.A.S.C. B.O.D. M.A.S.C Club Member

    Ya doesnt look plumbed right.
    Filter order is Sediment> Carbon > Membrane > DI
    DI is the last stage and the 'out' from the membrane should go to the DI
    I made same mistake when I built my RODI system. Blew through a full DI canister pretty quick because of it.
     
  7. tony02133

    tony02133 Cuttle Fish M.A.S.C Club Member

    can someone help me to get all this together?
     
  8. zombie

    zombie Tuna M.A.S.C Club Member

    The line from the carbon filter needs to go to the input of the membrane (left side). The black (waste) with the flow restrictor needs to go where the blue line is (Assuming your canister has them in the same place as mine. Whichever of the two has a high flow without the restrictor is the waste line and the RO line will have almost no flow) and the blue needs to go where the clear line is now (most likely) here are some pics of mine to give you a reference.

    20180603_062459-1440x1920.jpg 20180603_062527-1440x1920.jpg 20180603_062513-1600x1200.jpg 20180603_062520-1920x1440.jpg 20180603_062541-1440x1920.jpg 20180603_062545-1440x1920.jpg

    Sent from my SM-G965U using MASC mobile app
     
    Last edited: Jun 3, 2018
  9. tony02133

    tony02133 Cuttle Fish M.A.S.C Club Member

    ill try that when i get home thanks!!
     
  10. Gabe&Brandi

    Gabe&Brandi Copepod M.A.S.C Club Member

    Tony, when this is all set up and functioning you should swing by and practice installing another one at my house lol
     
  11. tony02133

    tony02133 Cuttle Fish M.A.S.C Club Member

    im done with this crap l
     

Share This Page